Sie sind nicht angemeldet.

tremheg

Bob der Baumeister

Beiträge: 4 845

Registrierungsdatum: 12. September 2013

Wohnort: Ehra-Lessien

Beruf: einfach Alles

Fahrzeug: VF W210 E270CDI

Name: Thomas

Danksagungen: 4948

  • Nachricht senden

41

Donnerstag, 17. Oktober 2019, 18:54

Wurden den die Unterdruckregler vom Turbo und AGR mal gegeneinander getauscht? An den Unterdruckreglern ist normalerweise ein kleiner Luftfilter, welcher verdreckt sein könnte. :hm:

Schau mal hier: (hier klicken). Dort wird jeder fündig!
Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren



  • »S210_OM611« ist der Autor dieses Themas

Beiträge: 20

Registrierungsdatum: 4. Oktober 2019

Wohnort: Herford

Fahrzeug: S210 220CDI OM611 DE 22 LA

Danksagungen: 13

  • Nachricht senden

42

Samstag, 19. Oktober 2019, 15:13

Weiter im Text

Hallo zusammen,

Danke nochmal für die Tipps, es geht weiter. Der Steckeradapter am Getriebe war schon gegen die neue Version bei der ATF-Spülung getauscht worden, habe trotzdem den neuen eingebaut und alles sauber gemacht, schadet ja nicht.

Die Druckdosen sind quergetauscht und funktionieren beide, Filter sind frei.

Heute morgen mal das Messen am AGR angefangen. Also: Alles angeklemmt und mal das LMM-Sensorsignal (Pin 5 weiß/gelb) gegen das Steuersignal der Druckdose (low-aktiv, grau-schwarz ) beobachtet. Die AGR-Druckdose wird per 12V/Bordspannung versorgt und mit dem zweiten Kabel (schwarz-grau, Pins müsste am MSG müsste ich nachschauen) gesteuert. Liegt an dieser Steuerleitung Bordspannung an, ist das AGR-Ventil komplett geschlossen (kein elektrisches Potential gegen die Versorgungsspannung), bei ca. 0,85V ist es komplett offen. Dann steuert die Druckdose den Unterdruck voll durch.

Die Stellung des AGR-Ventils ist lastabhängig. Bei Vollgas ist es komplett geschlossen ( = Bordspannung an der Steuerleitung). Im Leerlauf wird es nach einem Gasstoß erst komplett geöffnet, dann regelt es kurz hin und her um dann nach 60-90 Sekunden im Leerlauf dauerhaft zu schließen. Das jeweilige korrekte Öffnen und Schließen lässt sich am LMM-Signal gut nachvollziehen:

- AGR im Leerlauf voll auf: LMM-Signal ca. 1,85V, Steuerspannung auf Druckdose ist ca. 0,85V
- AGR im Leerlauf geschlossen: LMM Signal ca. 2,11V, Steuerspannung Druckdose dann Bordspannung.

Jetzt kommt die Krux: Wenn der Motor die 60-90 Sekunden im Leerlauf lief nimmt er problemlos Gas an. Nämlich dann wenn das AGR zu war. Gebe ich dann Gas, wenn das AGR teilweise oder voll offen war, taucht das Problem auf.

Also vermute ich, dass die AGR-Regelung im Leerlauf nicht stimmt und viel zu viel Abgas in den Ansaugtrakt gelangt. Wie gehabt schmeißt er dabei keinen Fehler.

Bin jetzt nochmal dran die AGR abzuschalten bzw. mechanisch abzuklemmen und das Signal mit einer kleinen Platine zu simulieren. Wenn das nichts bringt muss ein neues MSG her.

Was meint Ihr?

Gruß Simon

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »S210_OM611« (19. Oktober 2019, 15:30)


majesty78

keinen Titel. Titten reichen

Beiträge: 873

Registrierungsdatum: 28. August 2010

Wohnort: Zwettl, Waldviertel

Beruf: Selbstständiger Unternehmer

Verbrauch:

Fahrzeug: E 320 CDI

Name: Alex

Danksagungen: 342

  • Nachricht senden

43

Sonntag, 20. Oktober 2019, 09:52

Echt toll wie Du systematisch an die Sache rangehst!

Es hat sich bereits 1 registrierter Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

Orbaspain (21.10.2019)

  • »S210_OM611« ist der Autor dieses Themas

Beiträge: 20

Registrierungsdatum: 4. Oktober 2019

Wohnort: Herford

Fahrzeug: S210 220CDI OM611 DE 22 LA

Danksagungen: 13

  • Nachricht senden

44

Sonntag, 20. Oktober 2019, 14:11

Dem Ziel nah

So, nun geht es weiter, ich bin einer Lösung sehr nah.

Ich habe jetzt folgendes diagnostiziert: Die Abgasmenge im Leerlauf ist deutlich zu hoch, das Steuergerät wirft keine Fehler. Alle Sensoren und Aktoren scheinen ok zu sein. Daher muss der Fehler im Steuergerät selbst in der Signalverarbeitung liegen. Dagegen hilft ein Steuergerätetausch, der beim W210 aufgrund der FBS2/FBS3 nicht trivial ist und es auch kein allgemeines Erfolgsrezept gibt. Da jetzt keine weiteren Ansatz gab musste ich mir selbst helfen.

Die AGR-Abschaltung aus dem UK-Forum funktionierte bei mir am OM 611 (220CDI) nicht, da das LMM-Signal nicht korrekt verfälscht wird. Also habe ich mal ein bisschen überlegt, gerechnet und dann empirisch gemessen. Ziel war es mit einer Schaltung das Verhalten des AGR-Ventils am LMM-Signal nachzubilden. Im Leerlauf habe ich dazu die Schaltung anhand zweier Betriebspunkte ausgelegt (AGR voll auf und voll zu). Alles dazwischen ist als Betriebszustand schwierig herzustellen und auch schwierig zu messen. Daher habe ich mal vereinfacht ein lineares Verhalten angenommen (AGR halb auf wäre dann halbe Steuerspannung aus dem Steuergerät, der Einbruch am LMM-Signal wäre dann halb so groß, alles bei gleicher Drehzahl).

Das ganze wird dann anhand der Widerstandspaarung 100 Ohm/470 Ohm als Spannungsteiler eingestellt. Wichtig: Der Widerstand in der LMM-Leitung darf dann nicht zu groß werden, sonst verfälscht er das LMM-Signal zu stark, wenn auf der Steuerleitung oben Bordspannung liegt (AGR zu wäre das dann). Habe das ganze mal aufgezeichnet, alles etwas vereinfacht.

Achtung: Das ist kein generelles Rezept sondern muss natürlich auf den Motor mit viel Messen angepasst werden. Messtechnisch liege ich so jetzt mit den Werten sehr nah am funktionierenden AGR. Ströme habe ich alle gemessen, sind sehr nahe an den vorherigen Werten (überlebensnotwendig fürs Steuergerät) und die Widerstände werden auch nicht überlastet.

Mal ne Probefahrt gemacht, läuft bis jetzt astrein. Langzeittest steht noch aus. Ich werde berichten. Anbei nochmal 2 Fotos von dem ganzen in Theorie und Praxis. Wenn das dann läuft fahre ich nochmal zu MB und lösche die Fehler und schaue dann ob er nichts neues mehr ablegt. Wenn Ihr mögt berichte ich nochmal ausführlicher von den Messwerten. Das Steuergerät an sich ist damit natürlich nicht repariert, aber gekostet hat es bis jetzt nur Zeit und Hirnschmalz.

Gruß Simon

// Edit: Sorry ich weoß nicht wie ich das Bild drehe.
»S210_OM611« hat folgende Dateien angehängt:
  • IMG_8757.JPG (78,3 kB - 329 mal heruntergeladen - zuletzt: Gestern, 21:14)
  • IMG_8756.JPG (68,95 kB - 330 mal heruntergeladen - zuletzt: Gestern, 21:14)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »S210_OM611« (20. Oktober 2019, 14:13)


Es haben sich bereits 5 registrierte Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

pipapo129 (20.10.2019), sprinter (20.10.2019), Datong (21.10.2019), MB124 (22.10.2019), Bselecta (24.10.2019)

onkelaki

֎ amante della musica ֎

Beiträge: 15 584

Registrierungsdatum: 9. November 2007

Wohnort: München-Nord

Beruf: Leerling

Fahrzeug: 210.070

Danksagungen: 7553

  • Nachricht senden

45

Sonntag, 20. Oktober 2019, 14:18

Daumen hoch und Respekt ! :winke: Wer hat das Wissen --und die Ahnung-- unserer alten Elektronik zu trotzen und letztlich doch einen Erfolg zu feiern. Bin sicher, viele hier finden das gut und würden es gerne bei eigenen Problemen nachbauen. Klasse gemacht, die Elektroniker hier applaudieren :winke:

Es haben sich bereits 2 registrierte Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

flotter-cruiser (21.10.2019), Bselecta (24.10.2019)

pipapo129

Anlasserwagenfahrer

Beiträge: 707

Registrierungsdatum: 5. März 2014

Wohnort: Freiburg

Beruf: eher skeptisch

Verbrauch:

Fahrzeug: C200K S203 Opel Corsa C

Name: Peter

Danksagungen: 286

  • Nachricht senden

46

Sonntag, 20. Oktober 2019, 15:21

Nicht nur die! :streichel:

sprinter

Zeremonien-Meister

Beiträge: 12 675

Registrierungsdatum: 13. Dezember 2008

Wohnort: Wunstorf

Beruf: Berufskraftfahrer

Verbrauch:

Fahrzeug: Mercedes S210 E320

Name: Karl-Heinz

Danksagungen: 6579

  • Nachricht senden

47

Sonntag, 20. Oktober 2019, 16:53

Boah ey...ich komm gar nicht klar damit...alles böhmische Dörfer für mich.

Beiträge: 232

Registrierungsdatum: 7. Dezember 2015

Wohnort: Bad Oeynhausen

Fahrzeug: W210 320 CDI

Danksagungen: 29

  • Nachricht senden

48

Montag, 21. Oktober 2019, 00:13

Ist der Gartenschlauch geeignet? Ich frag ja nur mal so ;-)

Beiträge: 493

Registrierungsdatum: 18. August 2018

Wohnort: München

Fahrzeug: E500 M273

Danksagungen: 73

  • Nachricht senden

49

Montag, 21. Oktober 2019, 00:55

Da bin ich ja mal gespannt. Wenn das dauerhaft ohne Leistungsverlust funktioniert wäre super. Noch eine Blinddichtung uns AGR für alle Fälle und ab dafür.
Wie sieht jetzt eigentlich dein Motoröl aus nach den Fahrten mit erhöhter Rußbildung?
Ruß wandert zum kalten hin und setzt sich somit bei höherer Konzentration verstärkt an den Zylinderwänden ab und gelangt so ins Motoröl und erhöht neben der Viskosität auch den Verschleiß im Bereich der Steuerkette

  • »S210_OM611« ist der Autor dieses Themas

Beiträge: 20

Registrierungsdatum: 4. Oktober 2019

Wohnort: Herford

Fahrzeug: S210 220CDI OM611 DE 22 LA

Danksagungen: 13

  • Nachricht senden

50

Montag, 21. Oktober 2019, 09:28

Läuft

Zitat

Ist der Gartenschlauch geeignet? Ich frag ja nur mal so ;-)

Funktional ja, Langzeitresistenz gegen Hitze, Öl und Abgas bitte bei Gardena anfragen und die Antwort hier posten :D

Zitat

Da bin ich ja mal gespannt. Wenn das dauerhaft ohne Leistungsverlust funktioniert wäre super. Noch eine Blinddichtung uns AGR für alle Fälle und ab dafür.
Wie sieht jetzt eigentlich dein Motoröl aus nach den Fahrten mit erhöhter Rußbildung?
Ruß wandert zum kalten hin und setzt sich somit bei höherer Konzentration verstärkt an den Zylinderwänden ab und gelangt so ins Motoröl und erhöht neben der Viskosität auch den Verschleiß im Bereich der Steuerkette

Solange Druckdose und AGR in Ordnung sind ist das AGR-Ventil im spannungslosen Zustand zu. Die ganz ängstlichen könnten es ja zuschweißen :D. Motoröl, guter Einwand: Schwarz wie eh und je zuvor. Da die Rußbildung nur über ein paar Tage war und Langstrecke gefahren wird denke ich das geht in Ordnung.

Noch was: Es gibt bei der Star-Diagnose noch einen Stellgliedtest zur AGR. Den werde ich nochmal mit meiner Fake-Lösung machen. Wenn dann alles ok geht habe ich eine haltbare Dauerlösung. Verbrauch ist wie erwartet nochmals runtergegangen und Rußbildung geht gegen 0.

Gruß Simon

Beiträge: 493

Registrierungsdatum: 18. August 2018

Wohnort: München

Fahrzeug: E500 M273

Danksagungen: 73

  • Nachricht senden

51

Montag, 21. Oktober 2019, 10:41

Tröpfel mal das Öl auf ein Stück 80g Druckerpapier und lass 24 Stunden ziehen. Ob dann noch Ringe erkennbar sind oder es sich einfach nur um ein schwarzes Loch handelt. Der helle Rand , der im Gegenlicht sichtbar ist, ist der Kraftstoffeintrag.

Datong

Car HiFi Spezialist

Beiträge: 5 402

Danksagungen: 4639

  • Nachricht senden

52

Dienstag, 22. Oktober 2019, 11:31

Wenn Ihr mögt berichte ich nochmal ausführlicher von den Messwerten.

Das wäre super. Tolle pragmatische Lösung, gerade im Hinblick auf den erheblichen Aufwand welcher den Austausch des MSG darstellt.

Es hat sich bereits 1 registrierter Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

flotter-cruiser (22.10.2019)

  • »S210_OM611« ist der Autor dieses Themas

Beiträge: 20

Registrierungsdatum: 4. Oktober 2019

Wohnort: Herford

Fahrzeug: S210 220CDI OM611 DE 22 LA

Danksagungen: 13

  • Nachricht senden

53

Mittwoch, 23. Oktober 2019, 20:30

Na dann hole ich mal ein bisschen weiter aus. Messwerte sind aus dem Kopf, also besser selbst messen. Zumal eh jeder Motor da anders ist.

In der Theorie ist die Schaltung nicht genau zu spezifizieren, da sie nur ein Ausschnitt darstellt. Wir wissen leider nicht, wie das Steuergerät hinter den Pins aussieht und wie sich die Aktoren unter elektrischer Last verhalten. Insbesondere ist unbekannt, wie der Steuerausgang des AGR's beschaltet ist (OP's incl. Beschaltung etc.). Dies gilt ebenso für den Eingang des LMM-Signals (vermutlich hochohmig gegen Masse abgeschlossen). Erschwerend kommt hinzu, dass die Aktoren und Sensoren nicht gegen Karosseriemasse abgeschlossen sind. Das wird EMV-Gründe haben. Ein Ersatzschaltbild ist demnach nicht einfach, aber auch nicht unbedingt notwendig. Soviel zur Theorie.

Hauptsächlich wird über den "gesteuerte" Spannungsabfall über den 100 Ohm Widerstand erzeugt. Dieser sollte möglichst klein sein, damit das LMM-Signal möglichst gering beeinflusst wird, wenn die Diode gesperrt ist. In meinem Fall fielen im Leerlauf 30mV darüber ab, was respektive einem Strom von 0,3mA in das Steuergerät (LMM-Pin) entspricht, wenn das AGR zu ist. Sobald das Steuergerät das AGR über den Diodenzweig aufsteuert, fließt ein Strom durch die Diode in das Steuergerät (Steuerausgang AGR). Vermutlich wird dabei einfach nur der Eingangswiderstand im Steuergerät gegen Masse gesteuert. Dann fallen am 100 Ohm Widerstand ca. 250mV ab, was als Gesamtstrom des Stromteilers 2,5mA ist (trennt sich dann ja Richtung LMM und AGR Steuerausgang auf). Alle Teilströme sind für die Widerstände unkritisch, da die Verlustleistung fernab der Belastungsgrenze des 100 Ohm Widerstandes ist (er führt ja den Gesamtstrom).

Die Schaltung aus dem UK-Forum ist mir übrigens nicht geheuer, da kein definierter Spannungsteiler vorhanden ist und wir nicht wissen, inwieweit die Eingänge spannungs- oder stromgeregelt sind. Bei mir gab es keinen Spannungsabfall auf dem LMM-Signal, von daher würde ich da von Abstand nehmen. Die Kollegen dort hatten das auch eher auf dem 270/320CDI verbaut, da kann das Steuergerät schon mal ganz anders aussehen...

Man könnte jetzt natürlich noch tiefer einsteigen, aber das Auto soll ja wieder fahren anstatt tagelang "Re-Engineering" zu betreiben.

Wenn jemand so etwas nachbauen will empfehle ich das wirklich alles vorher (mit AGR dran) und nachher (mit Schaltung) zu messen und auf den Motor anzupassen.

Soweit alle Klarheiten beseitigt?

Gruß Simon

Es haben sich bereits 6 registrierte Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

flotter-cruiser (23.10.2019), ItsKiddow (23.10.2019), Datong (24.10.2019), SvenGM (24.10.2019), Bselecta (24.10.2019), *H4* (24.10.2019)

Beiträge: 66

Registrierungsdatum: 15. Juni 2019

Wohnort: Hamburg

Fahrzeug: W210 E280 4MATIC

Name: Jacob

Danksagungen: 16

  • Nachricht senden

54

Donnerstag, 24. Oktober 2019, 13:10

Ich verstehe vom Fach im Grunde nichts, möchte aber trotzdem sagen, dass ich von deiner Arbeit um das Problem zu lösen beeindruckt bin. Find ich geil.

majesty78

keinen Titel. Titten reichen

Beiträge: 873

Registrierungsdatum: 28. August 2010

Wohnort: Zwettl, Waldviertel

Beruf: Selbstständiger Unternehmer

Verbrauch:

Fahrzeug: E 320 CDI

Name: Alex

Danksagungen: 342

  • Nachricht senden

55

Samstag, 26. Oktober 2019, 08:52

Beeinflusst Deine "Add-On" Schaltung das Signal des LMM das an das MSG gemeldet wird?

Wenn ja, ist bei Fahrzeugen mit Automatik vorsicht geboten, da das LMM Signal eine der wichtigsten Eingangsgrößen für das GSG darstellt.

Anhand des LMM Signals wird ja die Motorlast an das GSG übermittelt und die Schaltvorgänge entsprechend dieses Signals angepasst/vorausberechnet.

Eine Verfälschung des LMM SIgnals wird daher zur Dekalibrierung der Daten führen die das GSG zur korrekten Funktion benötigt.

Datong

Car HiFi Spezialist

Beiträge: 5 402

Danksagungen: 4639

  • Nachricht senden

56

Samstag, 26. Oktober 2019, 09:07

So wie ich es nachvollziehen kann, regelt die Schaltung nur ein Schliessen des AGR im Leerlauf und beim Anfahren, danach geht die Regelung ganz normal wie üblich weiter, ohne weitere Beinflussung.

  • »S210_OM611« ist der Autor dieses Themas

Beiträge: 20

Registrierungsdatum: 4. Oktober 2019

Wohnort: Herford

Fahrzeug: S210 220CDI OM611 DE 22 LA

Danksagungen: 13

  • Nachricht senden

57

Samstag, 26. Oktober 2019, 11:13

Danke für das positive Feedback.

Komme gerade von der Star-Diagnose: Keine Fehler. Die AGR-Stellglieddiagnose ist leider nur eine Ist-Wertbeobachtung der Luftmasse mit Toleranzbereich. Das ganze ist sehr träge und nicht so sehr aussagekräftig wie ich es mir erhofft habe. Es wird aber keine Toleranzgrenze überstrapaziert sonst würde er ja einen Fehler werfen. Das Auto läuft wunderbar wie immer und hat volle Leistung, für mich ist die Sache damit abgeschlossen.

Anbei nochmal ein Bild vom Öl, da scheint mir kein Kraftstoffeintrag vorhanden zu sein.

Zitat

So wie ich es nachvollziehen kann, regelt die Schaltung nur ein Schliessen des AGR im Leerlauf und beim Anfahren, danach geht die Regelung ganz normal wie üblich weiter, ohne weitere Beinflussung.
Jein, die Schaltung beeinflusst jedes mal das LMM Signal, wenn das AGR aufgehen würde (hauptsächlich in Teillast, auch während der Fahrt). Der Spannungsabfall bei geschlossenem AGR liegt bei <1,5%, ich denke da wird jeder (Zubehör-)LMM weiter streuen. Und jetzt stellt euch nochmal einen undichten Ladeluftkreis vor, dann würde das LMM-Signal ja völlig daneben liegen und die berechnete Last garnicht mehr stimmen und sich GSG völlig "dekalibrieren".

Zitat

Eine Verfälschung des LMM SIgnals wird daher zur Dekalibrierung der Daten führen die das GSG zur korrekten Funktion benötigt.
Siehe oben. Zumal das Getriebesteuergerät das Rohsignal des LMM vermutlich nicht kennen wird, da es im MSG vorverarbeitet wird (oder anhand von Drehzahl und anderen Größen die Last berechnet wird). Welche Daten das Getriebesteuergerät genau erhält weiß ich nicht. Sicherlich stecken da viele Signalnormierungen, Entprellungen und Glättungen drin, die wir garnicht kennen. Ich kann daher nur sagen, dass die Verfälschung des Rohsignals verschwindend gering ist und m.M.n. in jeglichen Bauteiltoleranzen untergeht.

Viel interessanter zu wissen wäre jetzt abschließend nochmal, wie groß die Abgasrückführmenge bei einem intakten Motorsteuergerät ist. Also wie das AGR im Leerlauf korrekt regeln müsste (siehe mein letztes Video). Leider haben wir hier keine Vergleichswerte...


Gruß Simon
»S210_OM611« hat folgende Datei angehängt:
  • IMG_8786.JPG (148,4 kB - 60 mal heruntergeladen - zuletzt: Gestern, 21:14)

Es hat sich bereits 1 registrierter Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

Datong (26.10.2019)

Beiträge: 493

Registrierungsdatum: 18. August 2018

Wohnort: München

Fahrzeug: E500 M273

Danksagungen: 73

  • Nachricht senden

58

Samstag, 26. Oktober 2019, 14:16

Ne das schaut in Ordnung aus. Kein zackiger Rand für Wasser und wenn das Gegenlicht ist, auch kein Kraftstoffeintrag, oder zu kurz trocknen lassen. Etwas dunkel, aber keine Ahnung wie viele Betriebsstunden das schon drin ist. Deine Schaltung ist super. Solltest du mal als Service anbieten ;)

Zurzeit ist neben Ihnen 1 Benutzer in diesem Thema unterwegs:

1 Besucher

Social Bookmarks